woensdag 25 oktober 2006 @ 20:57:07 #1
4177 Jojogirl
Curves in all the right places
pi_42933882
In Excel prober ik ene sheet te maken die automatisch cellen volgooit.
In 1 kolom staat data, maar hierbij staat niet in elke cel iets. Of de cellen in deze kolom gevuld zijn of niet is willekeurig (de bovenste cel is wel altijd gevuld). In een andere kolom wil ik de data uit de eerste overnemen, maar daarbij moet als een cel in kolom 1 leeg was de waarde uit de cel daarboven worden gebruikt en als die ook leeg was uit de cel daarboven, etc etc.
Ik heb geprobeerd dit te doen met behulp vane en ALS formule, maar het werkt nog niet zoals ik wil, alleen bij het eerste lege vakje na een waarde in kolom 1 wordt die netjes overgenomen, bij de andere gaat het mis.
Hoe kan ik dit wel voor elkaar krijgen?

En voor de duidelijkheid, zo wil ik het eind resultaat dus hebben:

1
2
3
4
5
6
7
8
9
10
kolom 1  kolom2
AAAA     AAAA
BBBB     BBBB
         BBBB
         BBBB
CCCC     CCCC
         CCCC
DDDD     DDDD
EEEE     EEEE
         EEEE
  woensdag 25 oktober 2006 @ 21:07:02 #2
4177 Jojogirl
Curves in all the right places
pi_42934202
Tja, ik ben blond....

Het werkt dus wel als je tenminste de goede vakjes kiest bij True en False
pi_42934321
In B37 gooi het het volgende:
=ALS(A37="";B36;A37)

Je moet alleen in B1 even iets anders zetten. Zeg =A1.
Brutalen hebben de halve wereld; doe mij die andere helft dan maar
  woensdag 25 oktober 2006 @ 21:38:30 #4
4177 Jojogirl
Curves in all the right places
pi_42935333
Precies die fomule had ik dus ook, alleen had ik dus de laatste 2 celverwijzingen omgedraaid en dan gaat het mis

Maar bedankt voor je reactie, zo heeft iemand anders er misschien nog wat aan (met de formule erbij).

Forum Opties
Forumhop:
Hop naar:
(afkorting, bv 'KLB')